Work Market Disabling TLS 1.0 for API Integrations

Find out what's going on around Work Market

 

Starting in September 2016, Work Market will disable the TLS 1.0 encryption protocol. Once disabled, TLS 1.0 can no longer be used to access the Work Market website, API, or other services.  This article assists customers in supporting TLS 1.2 from applications that integrate with Work Market’s API and Call-outs.

Please read the Work Market Disabling TLS 1.0 article for information about web browser compatibility.  

 

Why is it changing?
In recent years, security researchers found a number of loopholes in the way encryption is handled, and some of the older browsers are known to be exposed to these security issues.  

Work Market web and API connections, along with mobile applications and notification services, use TLS as a key component of their security.  

At Work Market, trust is our #1 value, and we take the protection of our customers' data very seriously. The disablement of TLS 1.0 is being undertaken so we can maintain the highest security standards and promote the safety of your data as well as align with industry-wide best practices.

In addition, disabling TLS 1.0 is now a hard requirement for Payment Credit Industry Security Standard 3.1, an industry standard for securing systems used for credit card payments.   Although the PCI Security Council extended the deadline of this implementation until June 2018, Work Market believes it is important to protect and guard customer information as soon as possible.

 

What is the impact?
Customers with custom applications that integrates with Work Market through API will need to enable support TLS 1.2 encryption.  Customer applications that only support TLS 1.0 will lose their ability to integrate with the Work Market API after September 8, 2016.

 

Actions

Customers with custom applications that connect to the Work Market API will need to ensure that they support TLS 1.2.  This might require that customers update as follows:

Please consult your internal IT department for verification.

Testing

Please update your development or testing system to use the following “TLS 1.2 Only” endpoint to perform API system integration testing:  

https://dev.workmarket-api.com

Please note that your production system CANNOT integrate with Work Market’s API test end point.

Framework Checklist:

Microsoft .NET Framework 

.NET Version

Supportability

.NET 4.6 or Above

No Action Required

.NET 4.5

Supported but code modification required

.NET 4.0

Not Supported and code modification required

.NET 3.5 or below

Not Supported

Other Frameworks

Software / Version

Supportability

Java 8

No action required

Java 7

Not supported and Java properties modification required

Java 6

Not supported

Python 3.4 or above

Supported but code modification may be required

Python 3.0 to 3.3

Not supported

Python 2.7.9 or above

Supported but code modification may be required

Python 2.7.8 or below

Not supported

ColdFusion 10

Supported with ColdFusion 10 and Java 1.8

ColdFusion 9 or lower

Not supported

Other

If your application’s framework isn’t on this list, please consult your vendor documentation.

References

Have more questions? Submit a request

0 Comments

Please sign in to leave a comment.